# Table of Contents

## Part I Welcome to KooRaRoo Media

1. How to Buy KooRaRoo Media .......................................................... 6
2. Getting Help .................................................................................. 6

## Part II Getting Started

1. Using KooRaRoo Media ................................................................. 10
2. Main Window .................................................................................. 10
   - My Folders .................................................................................. 11
   - Status Pane ................................................................................ 11
   - Devices Pane ............................................................................... 11
   - Remote Player ............................................................................. 12

## Part III Reference

1. Dialogs .......................................................................................... 14
   - Add File ...................................................................................... 14
   - Add Metadata .............................................................................. 14
   - Add Predefined Playlist ............................................................. 15
   - Device ......................................................................................... 15
     - General ..................................................................................... 16
     - Transcoding ............................................................................ 16
     - Access Control ......................................................................... 17
     - Subtitles .................................................................................. 18
     - Advanced ................................................................................ 18
   - Disk Folder ................................................................................. 19
   - Dynamic File List ........................................................................ 20
   - Edit Metadata ............................................................................. 20
   - External Playlist .......................................................................... 21
   - File Properties ............................................................................ 22
     - General ..................................................................................... 22
     - Online Metadata ....................................................................... 23
     - Subtitles .................................................................................. 23
     - Transcoding ............................................................................ 24
   - Hierarchical Tree Playlist ............................................................ 24
   - Maintenance ............................................................................... 24
   - Online URL Properties ................................................................. 25
   - Options ........................................................................................ 26
     - General ..................................................................................... 26
     - Server ....................................................................................... 27
     - Update Folders .......................................................................... 28
     - Transcoding ............................................................................ 28
     - File Locations ........................................................................... 29
     - Advanced ................................................................................ 29
     - Defaults ................................................................................... 30
     - Parental Ratings ....................................................................... 30
   - Playlist ......................................................................................... 30
   - Prepare Files for Device ............................................................... 31
   - Register ........................................................................................ 32
   - Transcode File (Audio/Image) ....................................................... 32
   - Transcode File (Video) ................................................................. 33
   - Transcode Files .......................................................................... 34
   - Update Folder ............................................................................. 35
1 Welcome to KooRaRoo Media

KooRaRoo Media™ is more than a multimedia organizer or a media server. It has been created based on developer's extensive experience working with UPnP and DLNA devices and utilizes only the latest technologies to deliver you the best possible experience organizing, streaming and converting your media files. It has been designed to be as autonomous as possible to let you enjoy your media collection without having to return to your computer all the time.

KooRaRoo Media allows you to organize your media files using a variety of static and dynamic playlists. You are in complete control over how you wish your media library to look. KooRaRoo Media includes a media server that lets you stream your media files to DLNA and UPnP-compatible devices on your home network. It also includes a media controller that allows you to push files from your computer to compatible renderer devices. Files that are incompatible with your device will be automatically converted, based on the device definition. We are adding new devices all the time, as they are released by manufacturers.

There are many features for you to explore and we hope you enjoy using KooRaRoo Media!

Getting Started

- Work through the Getting Started section
- Visit the online community and don't hesitate to ask questions - we are always happy to talk to you!

1.1 How to Buy KooRaRoo Media

You can purchase KooRaRoo Media directly online, worldwide, using any major credit card or PayPal. As soon as your transaction is completed, you will receive a registration code via e-mail and you can continue using the program with all your data from the evaluation period intact.

Direct Order Link

http://www.kooraroo.com/purchase

Home Page Link

http://www.kooraroo.com

1.2 Getting Help

There are a number of different sources of help in KooRaRoo Media. In addition to this help file, you can also access the online user forum and contact support.
Displaying Help

- You can always press F1 to get access to this help from anywhere within the program.
- There are Help buttons on all windows to take you directly to the relevant topic.

Using the online community

The forum hosts an ever-growing community that brings together KooRaRoo Media users and developers. We’re very keen to hear your suggestions - that’s how KooRaRoo Media has always grown and we intend to keep it that way!

The forum is located at: http://forum.kooraroo.com - please take a moment to visit it now (it'll open in a new window), register and say "Hello" to us and everyone else!

Contacting support

Please visit http://www.kooraroo.com/support to send a direct message to support.

See also

- Getting Started

© 2012-2014 Programming Sunrise
2 Getting Started

This section takes you through the different parts of KooRaRoo Media, introducing you to its powerful, yet easy-to-use features.

Once you are familiar with the basics, it’s easy to find your way around KooRaRoo Media. However, there are detailed explanations of all dialogs (popup windows) in the Reference section and more useful information in the Frequently Asked Questions.

See also
- Getting Help
- Reference
- Frequently Asked Questions

2.1 Using KooRaRoo Media

KooRaRoo Media is a modern Windows-based application. You can perform almost any task in one of the four ways:

- Right-clicking on an item to bring up the context menu
- Clicking on the regular menus
- Clicking a toolbar button
- Using a keyboard shortcut

You can also:

- Find out more about any button by simply hovering over it to bring up a tooltip
- Press F1 at any time to get help

See also
- Getting Help

2.2 Main Window

The main window of KooRaRoo Media in its default form consists of the main media list surrounded by four panes: My Folders tree, Status pane, Devices pane and Remote Player pane.

You can right-click on items in the list to bring up a context menu with various actions available.

Clicking on header columns will sort by that column.

You can drag-and-drop files and folders from the list the tree.

Double-clicking on a file will bring up its properties, double-clicking on a folder will enter that folder.
2.2.1 My Folders

The My Folders tree is used to select the current folder.

This pane cannot be closed, but you can auto-hide it, if you wish to maximize the main list view.

You can drag-and-drop folders within the tree.

See also

- Main Window

2.2.2 Status Pane

The Status pane shows a current snapshot of KooRaRoo Media.

There are four main items displayed: System, Files, Streaming and Transcoding.

The System item shows various statistics about your media collection and also the status of the server and logging.

The Files item shows folders and files processing activity.

The Streaming item will show currently streaming files and the device they are being streamed to.

The Transcoding item will show the currently transcoded file and also the transcoding queue if there is more than one item.

See also

- Main Window

2.2.3 Devices Pane

The Devices pane lists all detected devices on your network.

Some devices can be auto-detected and they will have their device definition set correctly. Some devices will need manual adjustment, so you can right-click on such a device and bring up its properties.
See also

- Main Window

2.2.4 Remote Player

The Remote Player pane allows you to push files to compatible DLNA devices. A device must be a DMR (digital media renderer) to support the "play to" technology used by the Remote Player pane. All your compatible devices will be automatically listed here.

See also

- Main Window
Part III
3 Reference

This section contains documentation of all KooRaRoo Media’s options and associated dialogs (or popup windows as they may be called).

Studying this section is not absolutely essential, but it will make it easier for you to use KooRaRoo Media efficiently and effectively as well as give you insight into how some of the features work.

3.1 Dialogs

This section provides a reference to all dialogs (popup windows) that you can use in KooRaRoo Media and gives an overview of each dialog along with all the controls on each dialog.

See also

- Getting Started

3.1.1 Add File

From the Add menu select Add File.

The Add File dialog allows you to add a file to your media library. If the file was already added previously, it will just be added to the current playlist.

Descriptions:
- **File**: Enter the full path to the file. You can use the small button to browse for a file.

See also

- File Properties

3.1.2 Add Metadata

From the File Properties dialog click Add in the Metadata group.

The Add Metadata dialog allows you to add new metadata (dynamic criteria) to a file, which can then be used in dynamic playlists to organize your media files.

Descriptions:
- **Type**: Select the type of metadata you wish to add. You will see existing data of that type in the list and you can choose an existing value or add a new one.
- **Title**: Enter the value of metadata that you are adding if you are creating a new value.
3.1.3 Add Predefined Playlist

From the Add menu select Predefined Playlist.

The Predefined Playlist dialog allows you to add a dynamic file list or a hierarchical tree playlist that are already predefined for your convenience. You can use these as a base to modify them further or restore them in case you deleted them from the media library initially.

This feature is not available in Free version of KooRaRoo Media. See http://www.kooraroo.com/compare_features.php for a comparison chart.

Descriptions:
- Title: Enter a playlist name that will be used in your media library and will also be used on devices.
- Description: Add an optional description of this folder. You can see these description by using the View menu. Some devices may also support showing descriptions for files and folders.
- MPAA Rating: Set this to limit devices where this folder is displayed.

Tip: You can see the types of files a predefined playlist will support in the main list, e.g. if it starts with "Video:", it'll only show video files.

See also
- Dynamic File List
- Hierarchical Tree Playlist
- Options

3.1.4 Device

From the Devices menu select Edit.

The Device dialog allows you to alter various settings for a detected device.

For convenience it is split into four tabs - General, Transcoding, Access Control and Subtitles.

See also
- General tab
- Transcoding tab
- Access Control
- Subtitles
3.1.4.1 General

From the Device dialog select General.

Descriptions:

- **Name**: Give your device a friendly name that you will see in Status\(^1\) and Devices\(^1\) panes.
- **IP**: Shows the IP address at which this device is detected.
- **MAC**: Shows the unique MAC address of this device.
- **Device**: Allows you to select a device definition (device profile) for this device. Device definitions are used to define video, audio and image formats the device supports and other important information. For best possible experience, please choose a device profile that's designed for your device. In many cases KooRaRoo Media will auto-detect your device, but in some cases you will need to select a profile manually.
- **Allow access on IP**: Use this if you have more than one network card and you wish to limit network traffic to that specific card. It also helps if you are seeing multiple copies of the KooRaRoo Media server on your device, since there will be one instance per network card.
- **Region**: Some devices are region-based, so if you do not see files on your devices, try changing the region to match that of the device.
- **Image playback interval**: Specifies the number of seconds that photos shown on your device using Remote Player\(^1\) will wait before proceeding to the next photo. This is not an exact figure, because some photos may take longer to display on the device due to device's own internal decoding, so this interval may be reduced because of that.

**Note**: When the Device checkbox is ticked, the device profile is locked into your selection. When the checkbox is not ticked, KooRaRoo will attempt to auto-detect the device all the time. This helps when using KooRaRoo from a mobile device that has multiple players on it.

See also

- Devices Pane\(^1\)
- Status Pane\(^1\)
- Device\(^1\)

3.1.4.2 Transcoding

From the Device dialog select Transcoding.

Descriptions:

- **Transcode incompatible files**: Enable or disable transcoding (conversion) of files that cannot be natively played on your device.
- **Audio stream language priority**: If a file contains multiple audio streams, KooRaRoo Media can deliver audio in the language of your choice. This is particularly useful on devices that do not support multiple video/audio streams and will only pick the first one, or when the file needs to be transcoded. Languages should be entered using their three-letter code, such as: "eng,rus,ita". This will try to find an English language audio stream and deliver that first, if that fails, it'll try to find Russian and then Italian. If none are found or recognized, the first stream will be delivered. If you are not sure
about the correct code for your language, please ask on the forum or contact support.

- **Force aspect ratio:** When ticked, you can select to force the aspect ratio of the destination file to be 16:9 or 4:3. This will require a full re-transcode of the original files served to this device, so no remuxing is possible when this is ticked. It applies to all transcoded files for the device.

- **Upscale to 1920x1080:** When ticked the destination file will be 1920x1080 in size, upscaled and padded automatically. This only applies when the file needs to be fully transcoded. If the file can be remuxed, this setting has no effect.

- **Bitrate:** When ticked allows you to set the maximum bitrate that your network or device can handle. This will transcode more files than normal and may use more CPU, so please use only when necessary (e.g. when on a wireless network with low signal or a streaming to a mobile device that cannot handle higher bitrates).

- **Limit bitrate:** Allows you to adjust the maximum bitrate for files sent over the network (native and transcoded). Useful for wireless networks mostly to get rid of the stuttering.

- **Width** and **Height:** Allow you to set maximum width or height or both that all transcoded files will be limited to.

- **Automatically transcode new incompatible files:** When ticked will add files to the transcoding queue if they are deemed incompatible with this device upon adding them into the media library.

**Tip:** When you have "force aspect ratio" or "upscale" ticked, you can still override this for individual files in the Transcode File dialog.

### See also

- [Device](#)

#### 3.1.4.3 Access Control

From the Device dialog select Access Control.

**Descriptions:**

- **Rating:** Allows you to set a parental (as per MPAA) rating to limit the files delivered to this device.

- **Set different rating during the following hours:** Tick this to apply an alternative parental rating during certain hours.

- **Block device during the following hours:** Allows you to completely stop delivering files to a device during certain hours.

**See also**

- **Devices Pane**
- **Status Pane**
- **Device**
3.1.4.4 Subtitles

From the Device dialog select Subtitles.

Descriptions:

- **Enable burned-in subtitles**: Enable or disable burning in external subtitles (SRT, SMI, SUB) on top of the video.
- **Subtitle language priority**: Subtitle files can contain a language specifier in their filename in one of the following forms: "movie.en.srt", "movie.eng.srt", "movie-en.srt" or "movie-eng.srt". Where "en" or "eng" can be the two or three-letter ISO language codes. Languages should be entered using their three-letter code, such as: "eng, rus, ita". This will try to find an English language subtitle and burn that first, if that fails, it'll try to find Russian and then Italian. If none are found or recognized, the first external subtitle will be delivered (if there is any). If you are not sure about the correct code for your language, please ask on the forum or contact support.
- **Font name, size and color**: You can choose any of the available fonts and make it a certain size and color. You can choose smaller fonts for larger TVs and larger fonts for smaller TVs to make reading easier.
- **Encoding**: Allows you to set the code page that should be used when loading and rendering subtitles for this device. Some common code pages can be found here: http://en.wikipedia.org/wiki/Code_page
- **Scale**: Allow you to adjust the size of fonts in external subtitles that were designed to be a certain size and where multiple fonts are present. This keeps the same relation between existing font sizes, but lets you adjust the subtitle size in general to make it easier to watch on your device.

You can use the Generate Font Cache button to regenerate the fonts cache. This should be done if you add/remove fonts on your system.

See also

- Devices Pane
- Status Pane
- Device

3.1.4.5 Advanced

From the Device dialog select Advanced.

Descriptions:

- **Disable manufacturer-specific extensions**: When ticked it will remove special processing within KooRaRoo for certain devices. For example, Sony and Samsung devices will not show all folders when you browse their root by default, but if you tick this box, you can access your library's root folder and have it presented as-is on your device.
- **Capitalize folder titles**: When ticked will automatically capitalize the first letter of the first word of folder titles to accommodate devices that re-sort listings on their own and are case-sensitive.
See also

- Devices Pane
- Status Pane
- Device

### 3.1.5 Disk Folder

**From the Add menu select Disk Folder.**

The Disk Folder dialog allows you to add a folder located on a local or network drive to your media library. It is also used to change properties of an already existing disk folder.

**Descriptions:**

- **Title:** Enter a playlist name that will be used in your media library and will also be used on devices.
- **Folder:** Enter the full path to the folder. You can use the small button to browse for a folder.
- **Description:** Add an optional description of this folder. You can see these description by using the View menu. Some devices may also support showing descriptions for files and folders.
- **Extensions:** Enter file extensions that will be scanned in this folder and its subfolders. You can use Video, Photo and Music checkboxes to add and remove supported extensions to this list.
- **Automatically update:** Lets you enter a period when this folder will be re-scanned for new files and also any files that need to removed or updated. The settings used to control this are available on the Update Folders dialog from the Options menu. Typically frequently-updated folders (such as where you download your files to) will be updated more often, while more static folders are not updated at all or updated less frequently. You can also force an immediate update from the main menu.
- **MPAA Rating:** Set this to limit devices where this folder is displayed.
- **Include subfolders:** When ticked will also process all subfolders of the folder being added.
- **Configure how files are processed before adding them in:** Tick this to bring up an Update Folder configuration dialog that will let you specify how you want metadata to be processed when you click the OK button.

You can change the thumbnail for this folder by right-clicking on the picture in the top-left corner and using the popup menu to add a new image. Some devices will display these images when browsing folders.

**Tip:** You can add more than one physical disk folder by using the + button next to the folder path. This allows you to define a single root for multiple related disk folders.

See also

- Options
3.1.6 Dynamic File List

From the Add menu select Dynamic Playlist.

The Dynamic File List dialog allows you to add or edit the properties of a dynamic playlist based on file's dynamic criteria (metadata).

This feature is not available in Free version of KooRaRoo Media. See http://www.kooraroo.com/compare_features.php for a comparison chart.

Descriptions:

- **Title:** Enter a playlist name that will be used in your media library and will also be used on devices.
- **Description:** Add an optional description of this folder. You can see these description by using the View menu. Some devices may also support showing descriptions for files and folders.
- **Dynamic playlist criteria:** Allows you to add or remove dynamic criteria or file metadata that will be used to limit files shown in this playlist. You can use parentheses to build a hierarchy of criteria. You can check whether the criteria are valid or not by check the status - if it says Invalid, then this playlist cannot be saved. Once it says Valid, you can save the playlist.
- **Limit to:** Use this to further narrow down the result to a certain number of files.
- **Order by:** Allows you to override the default sorting order of this playlist.
- **MPAA Rating:** Set this to limit devices where this folder is displayed.

You can change the thumbnail for this folder by right-clicking on the picture in the top-left corner and using the popup menu to add a new image. Some devices will display these images when browsing folders.

Tip: You can recreate default dynamic file lists using the Add Predefined Playlist dialog.

See also

- Add Metadata
- Edit Metadata
- Hierarchical Tree Playlist
- Add Predefined Playlist

3.1.7 Edit Metadata

From the Tools menu select Edit Metadata.

The Edit Metadata dialog allows you to edit or consolidate existing metadata (dynamic criteria). A common use would be to correct misspelled values or combine multiple values into one.

Descriptions:

- **Type:** Select the type of metadata you wish to edit. You will see existing data of that type in the list and you need to select a value you wish to alter.
- **Combine with:** Ticking this box will allow you to combine both selected metadata
values into one - this will apply to all files where this criteria is used.
- **Title:** Enter the new value of metadata that you are editing.

### See also

- File Properties
- Add Metadata
- Dynamic File List
- Hierarchical Tree Playlist

### 3.1.8 External Playlist

**From the Add menu select External Playlist.**

The External Playlist dialog allows you to add a playlist file generated by other software to your media library. It is also used to change properties of an already existing playlist file. Supported playlists include iTunes XML library, M3U and M3U extended playlists, PLS playlists, Windows Media Player (WMP) playlists.

#### Descriptions:

- **Title:** Enter a playlist name that will be used in your media library and will also be used on devices.
- **Playlist File:** Enter the full path to the external playlist file. You can use the small button to browse for a file.
- **Description:** Add an optional description of this folder. You can see these description by using the View menu. Some devices may also support showing descriptions for files and folders.
- **Automatically update:** Lets you enter a period when this folder will be re-scanned for new files and also any files that need to removed or updated. The settings used to control this are available on the Update Folders dialog from the Options. Typically frequently-updated folders (such as where you download your files to) will be updated more often, while more static folders are not updated at all or updated less frequently. You can also force an immediate update from the main menu.
- **MPAA Rating:** Set this to limit devices where this folder is displayed.
- **Order by:** Allow you set per-playlist sorting order.
- **Codepage to use when reading the file:** If you see some files missing from the loaded playlist and they contain non-English characters, try changing the code page here and reload the playlist.

You can change the thumbnail for this folder by right-clicking on the picture in the top-left corner and using the popup menu to add a new image. Some devices will display these images when browsing folders.

### See also

- Options
3.1.9 File Properties

From the Actions menu select Properties.

The File Properties dialog allows you to change various properties for a file in to your media library. It is also used to change properties of an already existing file.

For convenience it is split into two tabs - General and Transcoding. Video files also show two additional tabs - Online Metadata and Subtitles.

Use the < and > buttons to move between files in the same folder.

Tip: Use the Actions drop-down menu to perform file-related actions.

See also

- General tab
- Online Metadata tab
- Subtitles tab
- Transcoding tab

3.1.9.1 General

From the File dialog select General.

Descriptions:

- **Title:** Enter a playlist name that will be used in your media library and will also be used on devices. You can also edit the internal sort title by clicking the small button inside the title edit window.
- **Ranking:** Set a file ranking on a scale of 1 to 10.
- **MPAA Rating:** Set the parental rating. This can be used to limit devices where this file will appear.
- **Play Count:** Shows how many times this file has been played on devices and the last play date and time. You can reset this back to zero or set it to the current time.
- **Last Played:** Allow you to set or reset the date when the file was played last on a device.
- **Description:** Add an optional description of this file. You can see these description by using the View menu. Some devices may also support showing descriptions for files and folders.
- **Track:** Adjust the track number.
- **Year:** Set the release year.
- **Month:** Set the release month.
- **Metadata type:** Lets you add or delete metadata (dynamic criteria) to this file.

You can change the thumbnail for the file by right-clicking on the picture in the top-left corner and using the popup menu to add a new image. Some devices will display these images when browsing files.

Use the < and > buttons to move between files in the same folder.
3.1.9.2 Online Metadata

From the File dialog select Online Metadata.

*Please note that currently this tab is available only for video files. Music files will be supported soon.*

**Descriptions:**
- **Title:** Enter a playlist name that will be used in your media library and will also be used on devices.
- **Source:** Choose the online metadata source site to retrieve information from.
- **Artwork:** Tick to replace artwork in the original file with the one found online.
- **Title:** Tick to replace the title of the original file with the one found online.
- **Date:** Tick to set the release date of the original file.
- **Ranking:** Tick to set the ranking of the original file using the one found online.
- **MPAA Rating:** Tick to set the parental rating of the original file using the one found online.
- **Description:** Tick to replace the description of the original file.
- **Metadata:** Tick to merge metadata found online with already existing metadata of the original file.
- **Replace or Merge:** Choose "replace" to completely overwrite existing metadata for the file with the new one or choose "merge" to combine the two together.

To search for online metadata, first please make sure that the movie title is correct. Edit it as necessary using the Title box provided on this tab. Once the title is correct, select an online source from the drop list and press **Search** to start searching. This will download some data, so it may take a few seconds, depending on your Internet connection and the amount of data received for a movie. You can use the left/right buttons < and > to browse through found items, if more than one has been found. To transfer data from this tab to the main file, tick the boxes of items that you wish to transfer and then click the **Apply** button. This will update the main record, but you may still Cancel the changes, because they are not saved until you have exited using the OK button.

Use the < and > buttons to move between files in the same folder.

**See also**

- [File Properties](#)

3.1.9.3 Subtitles

From the File dialog select Subtitles.
Descriptions:
- **Embedded subtitles**: Allow you to set a description and language for subtitles that are part of the video file. You can also delete unneeded or invalid streams or reload them from the file.
- **Available subtitles**: Shows subtitles that can be burned-in, these include embedded and external subtitles. Some properties can be adjusted, including converting subtitles to a different code page. You can see a preview of what the subtitle is in the provided window.

You can change the thumbnail for the file by right-clicking on the picture in the top-left corner and using the popup menu to add a new image. Some devices will display these images when browsing files.

Use the < and > buttons to move between files in the same folder.

**Tip:** When you change settings in the device transcoding tab, you may need to delete transcoded files here, to make sure those new settings take effect.

See also
- [File Properties](#)

### 3.1.9.4 Transcoding

From the File dialog select Transcoding.

Descriptions:
- **Transcoded Files**: Shows file formats this file has been converted to. You can delete or export (save as) these files.
- **Do not burn external subtitles** (video files only): When ticked, external subtitles for this file will be ignored when delivering it to the device. This takes precedence over any other setting (such as in Device properties).

You can change the thumbnail for the file by right-clicking on the picture in the top-left corner and using the popup menu to add a new image. Some devices will display these images when browsing files.

Use the < and > buttons to move between files in the same folder.

**Tip:** When you change settings in the device transcoding tab, you may need to delete transcoded files here, to make sure those new settings take effect.

See also
- [File Properties](#)

### 3.1.10 Hierarchical Tree Playlist

From the Add menu select Dynamic Playlist.
The Hierarchical Tree Playlist dialog allows you to add or edit the properties of a dynamic playlist that builds a hierarchy of subfolders based on file's dynamic criteria (metadata).

This feature is not available in Free version of KooRaRoo Media. See http://www.kooraroo.com/compare_features.php for a comparison chart.

**Descriptions:**
- **Title:** Enter a playlist name that will be used in your media library and will also be used on devices.
- **Description:** Add an optional description of this folder. You can see these description by using the View menu. Some devices may also support showing descriptions for files and folders.
- **Metadata tree and list:** Allow you to add, remove and rearrange metadata values that will be used as placeholders when building up a hierarchical tree.
- **Limit to:** Use this to further narrow down the result to a certain type or types of files.
- **MPAA Rating:** Set this to limit devices where this folder is displayed.
- **Order by:** Allow you set per-playlist sorting order.

You can change the thumbnail for this folder by right-clicking on the picture in the top-left corner and using the popup menu to add a new image. Some devices will display these images when browsing folders.

Tip: You can recreate default hierarchical tree playlists using the Add Predefined Playlist dialog.

**See also**
- Add Metadata
- Edit Metadata
- Dynamic File List
- Add Predefined Playlist

### 3.1.11 Maintenance

From the Tools menu select Maintenance.

The Maintenance dialog allows you to perform database maintenance on your library files. Typically you'll want to do this after deleting many files to reduce the database size or after editing many files to optimize the database.

Maintenance needs to lock down your database, so browsing and streaming may be affected. It's recommended that you do not perform any server or application (GUI) tasks during maintenance.

### 3.1.12 Online URL Properties

From the Add menu select Online URL.

The Online URL Properties dialog allows you to add an online URL to your media library. If the online URL was already added previously, it will just be added to the current playlist.
At the moment only http audio streams are supported, but this will be expanded in future updates.

**Descriptions:**
- **URL:** Enter the full URL here - it can be a direct URL or an ASX/M3U/PLS/WPL playlist.
- **Title:** Enter the title of the online URL here. It may be automatically parsed from the playlist, if the playlist contain this information.
- **Description:** Add an optional description of this online URL. You can see these description by using the View menu. Some devices may also support showing descriptions for files and folders.
- **MPAA Rating:** Set this to limit devices where this online URL is displayed.

After you enter or modify the online URL, press the Test URL button. It may take a few seconds and at the end if it succeeds, you'll see the URL and the OK button enabled. If for some reason it fails, you'll get an error message. Please contact support in case of an error, so that we can add support for more types of URLs.

**See also**
- [File Properties](#)

### 3.1.13 Options

From the Tools menu select Options.

The Options dialog enables you to configure the various settings that KooRaRoo Media has.

**See also**
- [General](#)
- [Server](#)
- [Update Folders](#)
- [Transcoding](#)
- [File Locations](#)
- [Advanced](#)
- [Defaults](#)
- [Parental Ratings](#)

#### 3.1.13.1 General

Use these settings to adjust how the program (GUI) is loaded.

**Descriptions:**
- **Automatically run on Windows startup:** When ticked will run KooRaRoo Media GUI when Windows is started. This is different from starting the server.
- **Show splash screen while loading:** You can toggle whether the splash screen is shown during loading.
- **Start minimized:** When ticked, the GUI will start in minimized state.
- **Minimize on closing:** Lets you minimize the GUI instead of closing it when clicking on
the close button. Use File menu to exit the GUI completely.

- **Minimize to system tray**: When ticked will not show an entry on the taskbar, but will instead show an icon in the system tray.
- **Always show tray icon**: When ticked will show an icon in the tray when the GUI is running.
- **Check for updates when program starts**: Lets KooRaRoo Media automatically check for updates when the GUI is started. If an update is found, you'll be prompted to download and install it. You can also check for updates using the Help menu.
- **Theme**: Allows you to customize the way KooRaRoo GUI looks to better suit your personal taste.
- **Lock current window layout**: Tick this to lock all panes as they are currently to prevent them from being accidentally moved or closed.

**See also**

- Options

### 3.1.13.2 Server

Use these settings to control server-specific options.

**Descriptions:**

- **Server Name**: Lets you change the server name that is shown on devices.
- **Server Port**: Lets you adjust the TCP port used by KooRaRoo Media server to connect to your network. Please make sure this port is open in your firewall.
- **Allow new devices to connect by default**: When ticked, any new device on the home network will be allowed to access KooRaRoo, otherwise (when unticked), devices will be denied access initially and you will have to explicitly grant access rights to them.
- **Set default MPAA rating for new devices**: You can select a default parental rating that will be applied to new devices using this option.
- **Use only MAC address to detect devices**: When ticked, the devices will be matched to existing device profiles using only their MAC address. If you have a network bridge, this may fail, as some network bridges mask their clients' MAC address behind their own. If you don't have a network bridge, but your router tends to change IP addresses for your devices often, tick this box to speed up detection.
- **Start server when Windows loads**: Tick this to have the server start with Windows (without the need for you to login).
- **Percent of file played to update the playcount**: Set this in percent (from 10 to 100) to trigger the play count update when streaming files.
- **Show playcount on the device**: Allows you to distinguish files that you already played using either an asterisk in the front or a play count after the title.

You can use the **Register Windows Service** button if the stop/start button on the toolbar is not working, this can happen if you change your user's permissions on the system. Alternatively, just re-install KooRaRoo and the service will be re-registered automatically.

**See also**

- Options
3.1.13.3 Update Folders

Use these settings to specify default options when updating disk folders.

**Descriptions:**
- **Add new files and folders to your media collection:** When ticked will cause new files and folders that are found to be added to your library.
- **Delete inaccessible files and folders from your media collection:** Tick this to remove files that cannot be accessed from your library. If you are updating folders on an external drive, please make sure it is plugged in and operational when this option is ticked, otherwise those files will be removed from your media collection and you’ll have to re-add them.
- **Update existing files:** When ticked will make KooRaRoo Media check your existing files for missing metadata or thumbnails and update as necessary.
- **Reload file thumbnails, replacing existing artwork:** Tick this to completely replace existing artwork (not just update missing one) when updating the folder.
- **Load metadata from media files:** When ticked KooRaRoo will attempt to read and process metadata stored in media files themselves.
- **Create thumbnails from media files:** When ticked thumbnails will be created for video, music and photo files by grabbing a frame from video or photo or reading in metadata for music.
- **Use external files for video thumbnails:** Tick this to try and load video thumbnails from folder.jpg and other image files located in the same or artwork folders.
- **Load external subtitle files:** When ticked, external subtitle files such as SRT, SMI and SUB will be processed when updating files in folders. New subtitles will be added in and non-existing ones removed.

**See also**

- Options

3.1.13.4 Transcoding

Use these settings to control the size of the transcoding folder.

**Descriptions:**
- **Delete oldest files once folder reaches:** Lets you set a maximum size that the transcoding folder can reach.
- **Delete files older than:** When set will delete any transcoded file older than a certain number of days, regardless of the maximum size setting.
- **Process manual transcoding during set hours:** When set will only convert files during the set period. This doesn't affect streaming and can be used to optimize your CPU usage by making it pretranscode files when the computer is not in use.

You can use **Delete all transcoded files** and **Delete thumbnails** buttons to clear up the transcoding cache without waiting for its natural maintenance due to size or age.

**See also**

- Options
3.1.13.5 File Locations

These settings allow specifying folder where files used and/or generated by KooRaRoo Media are stored.

**Descriptions:**
- **Logs:** Shows the folder where log files will be placed.
- **Transcoding:** Shows/sets the folder where transcoded files will be generated.
- **Transcoders:** Shows/sets the folder where transcoding engine executables are located.
- **Artwork:** Shows/sets a folder where additional artwork is located.
- **Subtitles:** Shows/sets a folder where additional subtitle files are located.
- **Databases:** Shows/sets a folder where database files are located.

**See also**
- **Options**

3.1.13.6 Advanced

Use these settings to adjust various advanced configuration options to fine-tune your KooRaRoo experience.

**Descriptions:**
- **Do not use metadata for the title:** When ticked will not read in the title from metadata, but will always use the original file name. Useful if you rename and organize files in your own way.
- **Update disk folders while streaming:** When unticked it will not run the automatic folder update when something is streaming. Useful if you have a lower-spec CPU that may struggle with transcoding/streaming and updating folders at the same time.
- **Load online metadata when processing music files:** When ticked, if a music file does not have an external or embedded thumbnail, KooRaRoo will try to find one online. This is typically queued and is processed at roughly one thumbnail per second.
- **Load online metadata when processing video files:** When ticked, checks online metadata sources to try and load metadata for the video file, including a thumbnail.
- **Do not add album artwork files to the library:** When ticked, files that are used for album artwork and thumbnails will not be added to the media library, so that it looks cleaner. These files are typically small and your normal photos are not affected.
- **Load embedded subtitles from video files:** When ticked will extract embedded subtitles from video files, so that they can be used for device that do not supported embedded subtitles.
- **Do not create thumbnails from video frames:** When ticked will not attempt to create a thumbnail from the video file itself if there is no online or disk thumbnail.
- **Do not load embedded metadata:** When ticked will not spend time reading files to extract any metadata stored int them. Use this to speed up processing of files if you know they don't contain metadata or you don't use dynamic playlists.
- **External subtitles codepage:** Allows you to set the code page that should be used when loading external subtitles.
- **Thumbnail size:** Allows you to set the thumbnail dimensions as stored in KooRaRoo's database. Most DLNA devices require only 160x160 pixels, but some require more and you can adjust this setting here. After changing it, you need to re-scan your library.
(using "Update Existing Files") and also use the Delete Thumbnails button on the Transcoding page.

**See also**
- Options

### 3.1.13.7 Defaults

Use these settings to define default actions and default selections to suit your personal preferences.

**Descriptions:**
- **Double-click on a file:** Defines the action when you double-click on a file in KooRaRoo's main view.
- **Online metadata site for videos:** Specifies the default online metadata site selected when you retrieve online metadata for video files.

**See also**
- Options

### 3.1.13.8 Parental Ratings

Use these settings to rename default parental ratings.

Parental ratings are processed in the order they appear, for example: CUSTOM1 will be more strict than NC-17.

**See also**
- Options

### 3.1.14 Playlist

**From the Add menu select Playlist.**

The Playlist dialog allows you to add a static playlist that you can use as a placeholder for other playlists or files.

**Descriptions:**
- **Title:** Enter a playlist name that will be used in your media library and will also be used on devices.
- **Description:** Add an optional description of this folder. You can see these description by using the View menu. Some devices may also support showing descriptions for files and folders.
- **MPAA Rating:** Set this to limit devices where this folder is displayed.
• **Order by:** Allows you to override the default sorting order of this playlist.

You can change the thumbnail for this folder by right-clicking on the picture in the top-left corner and using the popup menu to add a new image. Some devices will display these images when browsing folders.

**See also**

- Options

### 3.1.15 Prepare Files for Device

**From the Tools menu select Prepare Files for Device.**

The Prepare Files for Device dialog lets you find and transcode (convert) files that cannot be played natively on a particular device to a format that can be played on the device.

**This feature is not available in Free version of KooRaRoo Media. See [http://www.kooraroo.com/compare_features.php](http://www.kooraroo.com/compare_features.php) for a comparison chart.**

**Descriptions:**

- **Device:** Lets you choose a device that you wish to convert files for.
- **Video, Photo, Music:** Tick one or more to display corresponding file types from your media library.
- **Show only untranscoded files:** When ticked will only show files that still need to be transoded. Unticked will show all incompatible files for a device, regardless of whether a file has already been transcoded or not.
- **Transcode native files:** When ticked will convert files that can be played on the device natively. If not ticked, it will skip over files that do not need transcoding.
- **Prepare thumbnails:** Tick this to also create thumbnails for the selected device in advance.

You can use **Check All** and **Uncheck All** buttons to quickly select and deselect all files in the list for pretranscoding. **File Information** button will bring up diagnostic file information that can show why the file is deemed incompatible.

After you click **Start**, files will be added to the transcoding queue. If the queue is empty, they will start transcoding straight away. You can check the transcoding queue using the **Status** pane.

**See also**

- Device
- Transcode File (Audio/Image)
- Transcode File (Video)
- Transcode Files
3.1.16 Register

From the Help menu select Register.

The Register dialog lets you enter your license information to unlock the trial.

Descriptions:
- **Name:** Enter your name, it must match the name you've entered when you purchased your license.
- **Code:** Enter the registration code that you've received via e-mail after your purchase.

You can use the Paste button to automatically populate the fields with correct information, provided you've following instructions in your registration e-mail.

See also
* How to Buy KooRaRoo Media

3.1.17 Transcode File (Audio/Image)

From the Actions menu select Transcode.

The Transcode dialog lets you transcode (convert) a file to a different format.

This feature is not available in Free version of KooRaRoo Media. See http://www.kooraroo.com/compare_features.php for a comparison chart.

Descriptions:
- **Title:** Shows the title of the currently selected file.
- **Device:** Lets you choose a device that you wish to convert the file for.
- **Original file format:** Displays the format of the original file.
- **Original file codec:** Lets you choose the stream you wish to convert, if there is more than one in the file.
- **Transcoded file format:** Lets you choose the destination file format.
- **Transcoded file codec:** Lets you choose the destination format codec, if there is more than one available.

After you click OK, the file will be added to the transcoding queue. If the queue is empty, it will start transcoding straight away. You can check the transcoding queue using the Status pane.

See also
* Device
* Transcode File (Video)
* Transcode Files
* Prepare Files for Device
3.1.18 Transcode File (Video)

From the Actions menu select Transcode.

The Transcode dialog lets you transcode (convert) a file to a different format.

This feature is not available in Free version of KooRaRoo Media. See http://www.kooraroo.com/compare_features.php for a comparison chart.

Descriptions:
- **Title**: Shows the title of the currently selected file.
- **Device**: Lets you choose a device that you wish to convert the file for.
- **Original file format**: Displays the format of the original file.
- **Original file video**: Lets you choose the video stream you wish to convert, if there is one or more in the file. If you untick this box, the destination file will not have a video stream.
- **Original file audio**: Lets you choose the audio stream you wish to convert, if there is one or more in the file. If you untick this box, the destination file will not have an audio stream.
- **Original file subtitle**: Lets you choose the subtitle stream you wish to convert, if there is one or more in the file. If you untick this box, the destination file will not have an embedded subtitle stream. In the current version, subtitles can only be copied, but not converted to a different format.
- **Original file external subtitle**: Lets you choose an external subtitle that you want to burn on top of the video or embed as an additional stream in the resulting file. If none are available, then this will be disabled.
- **Transcoded file format**: Lets you choose the destination file format.
- **Transcoded file video**: Lets you choose the destination format video codec, if there is more than one available.
- **Transcoded file audio**: Lets you choose the destination format audio codec, if there is more than one available.
- **Transcoded file subtitle**: Let you choose whether to copy the embedded subtitles or drop them from the destination file.
- **Full transcoding (no remuxing)**: By default KooRaRoo Media will attempt to remux (copy) a stream if it finds it to be compatible. In some cases devices cannot play remuxed streams due to device’s firmware limitations and in this case you can tick this box and the file will be fully transcoded, making it more compatible.
- **Audio sync**: If you find audio out of sync with video after conversion, try ticking this box and re-transcoding.
- **Force aspect ratio**: When ticked, you can select to force the aspect ratio of the destination file to be 16:9 or 4:3. This will require a full re-transcode of the original file, so no remuxing is possible when this is ticked.
- **Upscale to 1920x1080**: When ticked the destination file will be 1920x1080 in size, upscaled and padded automatically. This only applies when the file needs to be fully transcoded. If the file can be remuxed, this setting has no effect.
- **Force frame rate**: Enable this to specify a particular frame rate for the resulting file such as 25, 29.97, 30, 50, etc... This setting is encoding codec-specific.

After you click **OK**, the file will be added to the transcoding queue. If the queue is
empty, it will start transcoding straight away. You can check the transcoding queue using the Status pane.

**Tip:** Eventhough specifying a forced aspect ratio will require full transcoding most of the time, KooRaRoo Media will attempt to match the selected aspect ratio to the original file's aspect ratio and if they match, then remuxing is possible. This only works for 16:9, 4:3 and 5:3 aspect ratios.

**Tip:** Original file subtitle and external subtitle checkboxes are mutually exclusive. If one is ticked, the other will be disabled, even if subtitles exist. You can only select one at a time.

### See also

- [Device](#)
- [Transcode File (Audio/Image)](#)
- [Transcode Files](#)
- [Prepare Files for Device](#)

#### 3.1.19 Transcode Files

From the Actions menu select Transcode.

The Transcode dialog lets you transcode (convert) multiple files to a different format.

*This feature is not available in Free version of KooRaRoo Media. See [http://www.kooraroo.com/compare_features.php](http://www.kooraroo.com/compare_features.php) for a comparison chart.*

**Descriptions:**

- **Files to be transcoded:** Shows currently selected file that will be transcoded. You can add or delete files using controls provided.
- **Device:** Lets you choose a device that you wish to convert files for.
- **Transcode native files:** When ticked will convert files that can be played on the device natively. If not ticked, it will skip over files that do not need transcoding.
- **Re-transcode already converted files:** When ticked will delete already transcoded files, if they exist, and perform conversion again.

After you click OK, files will be added to the transcoding queue. If the queue is empty, they will start transcoding straight away. You can check the transcoding queue using the Status pane.

### See also

- [Device](#)
- [Transcode File (Audio/Image)](#)
- [Transcode File (Video)](#)
- [Prepare Files for Device](#)
3.1.20 Update Folder

The Update Folder dialog lets you adjust settings before updating a disk folder.

Descriptions:
- **Add new files and folders to your media collection**: When ticked will cause new files and folders that are found to be added to your library.
- **Delete inaccessible files and folders from your media collection**: Tick this to remove files that cannot be accessed from your library. If you are updating folders on an external drive, please make sure it is plugged in and operational when this option is ticked, otherwise those files will be removed from your media collection and you'll have to re-add them.
- **Update existing files**: When ticked will make KooRaRoo Media check your existing files for missing metadata or thumbnails and update as necessary.
- **Reload file thumbnails, replacing existing artwork**: Tick this to completely replace existing artwork (not just update missing one) when updating the folder.
- **Load metadata from media files**: When ticked KooRaRoo will attempt to read and process metadata stored in media files and external metadata files.
- **Create thumbnails from media files**: When ticked thumbnails will be created for video, music and photo files by grabbing a frame from video or photo or reading in metadata for music.
- **Use external files for video thumbnails**: Tick this to try and load video thumbnails from folder.jpg and other image files located in the same or artwork folders.
- **Load external subtitle files**: When ticked will try to find and process external (SRT, SMI, SUB, etc...) subtitle files.
- **Do not load embedded metadata**: Tick this to not read metadata stored in the file itself.

Default settings for this folder are set using the Update Folders options dialog.

See also
- **Options**

3.1.21 Welcome

The Welcome to KooRaRoo Media dialog lets you add folders to the library on the initial run of the application.

Descriptions:
- **Choose folders to add**: Lists some pre-defined folders, if they are found on your system, such as your My Videos, My Music and My Photos. You can add or remove folders using controls provided.
- **Start the media server now**: When ticked will start the media server when you click the OK button, allowing you to start streaming files as they are being added.
- **Configure how files are processed before adding them in**: Tick this to bring up update folders configuration options that will let you specify how you want metadata to be processed when you click the OK button.
- **Configure advanced file processing options before starting**: Tick this to configure advanced file processing options before adding in selected folders.
3.2 Command-line Arguments

You can run the server with the following command-line arguments (for example to script actions). Please note that this is for advanced users only. If in doubt, please ask us first.

Command-line Arguments

- **delete** Delete all user-created files, including databases and transcoded files. Original media files are never touched or deleted.
- **files** Adds an exception for the server to the built-in firewall.
- **firewall** Runs server as a console app, not as a service. To exit it, use Ctrl+C.
- **install** Registers the server with the control manager.
- **start** Starts the currently registered server.
- **stop** Stops the currently registered server.
- **stopa** Stops the currently registered server without prompting for admin privileges (on Vista and above). You need to run the command-line prompt as administrator for this to succeed.
- **uninstall** Removes the server from the control manager.
Part IV
4 Frequently Asked Questions (FAQs)

For the most up-to-date Frequently Asked Questions please visit our online community.

See also

- Getting Started
- Reference
Part V
5 Tutorials

You can find video tutorials and program screenshots on this page: http://www.kooraroo.com/tutorials.php

See also

- Getting Started
- Reference
6 Web Interface

You can access your files from any Web-browser in the world by configuring the web interface in KooRaRoo. For instructions on how to do this, please see this forum post: Setting up Web Interface in KooRaRoo Media

See also

- Getting Started
- Reference
Index

- A -
access 16
access files via Internet 42
add 28
add disk folder 19
add file 14
add metadata 14
album 22
alternative parental rating 17
arguments 36
artwork files location 29
asx 25
audio stream 16
audio sync 33
automatically run 26
automatically update 19

- B -
block device 17
burned-in subtitles 18, 23, 33
buy 6

- C -
capitalize folder names 18
check for updates 26
combine metadata 20
command-line 36

database 25
database location 29
delete 28
deletefiles 36
device 16
device definition 16
device profile 16
devices pane 11
dialogs 14
different parental rating 17
digital media renderer 12
disk folder 19
dmr 12
dynamic criteria 14, 15, 20, 24
dynamic file list 15, 20
dynamic playlist 15, 20
edit metadata 20
embedded subtitles 23, 33
extensions 19
external playlist 21
external subtitle files 28
external subtitles 18, 23, 24, 28, 33
faq 38
file 14
file location options 29
file properties 22
firewall 36
folder 15, 19, 20, 21, 24
folders tree 11
font cache 18
font color 18
font name 18
font size 18
foreground 36
general options 26
generate font cache 18
getting help 6
getting started 10
gui 10
help 6
hierarchical tree playlist 15, 24
how to 40
how to buy 6
how to purchase 6
incompatible files 31
install 36
Internet interface 42
internet radio 25

© 2012-2014 Programming Sunrise
ip 16
itunes 21

- J -

japan 16

- K -
korea 16

- L -
language 16
license 32
lock layout 26
logs location 29

- M -
m3u 21, 25
mac 16
mac address 27
main window 10
maintenance 25
manufacturer extensions 18
metadata 14, 15, 20, 22, 24, 28, 29
metadata hierarchy 15, 24
minimize on closing 26
minimize to system tray 26
mpaa 22, 27
mpaa rating 16, 17, 22
my folders 11

- N -
ntsc 16

- O -
online metadata 23
online URL 25
optimize 25
order link 6

- P -
pal 16
parental controls 17

parental rating 16, 22, 27, 30
play count 22
play to 12
playcount 27
playlist 15, 19, 20, 21, 24, 30
pls 21, 25
popup windows 14
predefined playlist 15
pretranscode files 31
purchase 6
push to 12

- R -
rating 22
reference 14
region 16
register 32
registration code 32
reload 28
remote player pane 12
remux 33
re-transcode files 34

- S -
samsung 18
screenshots 40
server name 27
server options 27
server port 27
show playcount 27
show splash 26
smi 28
sony 18
sort title 22
srt 28
start 6, 10, 36
start minimized 26
start server 27
status pane 11
stop 36
stopasadmin 36
streaming 29
sub 28
subtitle code page 23
subtitle files location 29
subtitle properties 23
subtitles 18, 23
subtitles language 18
supported files 19

- T -

theme 26
thumbnail 19, 20, 21, 24
thumbnails 28
time limit device 17
transcode 16
transcode audio 32
transcode file 32, 33
transcode files 34
transcode image 32
transcode native files 34
transcode video 33
transcoded files 22, 24
transcoders location 29
transcoding 16
transcoding files location 29
transcoding folder size 28
transcoding options 28
tray icon 26
tutorials 40

- U -

uninstall 36
update 28, 29
update folder 19, 35
update folders options 28
using 10

- V -

video metadata 23
video thumbnails 28
video tutorials 40
videos 40

- W -

walkthroughs 40
web interface 42
welcome 6, 35
windows 14
wmp 21
wpl 25
www interface 42